Resolved
Blank Screen on Philo.com (WEB)

Started
October 20, 2021 at 11:07 AM
Status
Resolved after about 3 hours
Affected
Video
Sign Up
Sign In

Impact

Operational
  • Resolved
    October 20, 2021 at 1:42 PM

    We just resolved the issue—Thank you for your patience and understanding.

  • Identified
    October 20, 2021 at 12:00 PM

    We are continuing to work on a fix for this incident.

  • Investigating
    October 20, 2021 at 11:07 AM

    We are currently investigating this incident.