Resolved
Our phone line is currently experiencing issues.

Started
March 22, 2022 at 4:14 PM
Status
Resolved after about 1 hour
Affected
help.philo.com

Impact

Operational
  • Resolved
    March 22, 2022 at 5:14 PM

    We are happy to share that our phone line is no longer experiencing any issues.

  • Identified
    March 22, 2022 at 4:29 PM

    We are continuing to work on a fix for this incident but in the meantime, please feel free to chat in with one of our agents or send us an email at help.philo.com.

  • Investigating
    March 22, 2022 at 4:14 PM

    We are currently investigating this incident.