Resolved
Our phone line is currently experiencing issues.

Started
March 28, 2022 at 3:50 PM
Status
Resolved after less than a minute
Affected
help.philo.com

Impact

Minor outage
  • Resolved
    March 28, 2022 at 3:50 PM

    Our phone line is currently experiencing issues. Our team is aware and is currently working on a fix as soon as possible.