Resolved
Active Outage: Phone system issues

Started
May 18, 2023 at 11:36 PM
Status
Resolved after 32 minutes

Impact

Partial outage
Affected
help.philo.com
  • Resolved

    Our phone system is now operational.

  • Identified

    We are currently experiencing issues with our phone system. We are not able to accept incoming calls.