Philo - Channel down: Cheddar News – Incident details

Channel down: Cheddar News

Resolved
Partial outage
Started about 1 year agoLasted 2 days

Affected

Video

Partial outage from 5:16 PM to 12:21 AM

Updates
  • Resolved
    Resolved

    Cheddar News is up and running again. Thanks for your patience!

  • Identified
    Identified

    We have identified an issue with Cheddar News and are working to restore things as quickly as possible. We will post updates here as they become available.