Philo - Channel outage: Heroes & Icons and American Heroes Channel – Incident details

Channel outage: Heroes & Icons and American Heroes Channel

Resolved
Operational
Started 9 months agoLasted about 2 hours

Affected

Video

Operational from 1:46 AM to 4:02 AM

Updates
  • Resolved
    Resolved

    Heroes & Icons as well as American Heroes Channel are back up and running.

    Thank you for your patience while we resolved this issue.

  • Identified
    Identified

    We have identified an issue with Heroes & Icons and are working to restore things as quickly as possible. We will post updates here as they become available.