Philo - Video playback freezing on Roku G000x/H000x models – Incident details

Video experiencing degraded performance

Video playback freezing on Roku G000x/H000x models

Identified
Degraded performance
Started about 17 hours ago

Affected

Video

Degraded performance from 4:00 PM to 12:00 AM

Updates
  • Identified
    UTC
    Identified

    Roku has identified the error causing the spike in playback issues for the affected devices.

  • Investigating
    UTC
    Investigating
    We are currently investigating this incident.