Philo - Channel outage: all AMC channels – Incident details

Channel outage: all AMC channels

Resolved
Partial outage
Started 24 days agoLasted about 2 hours

Affected

Video

Partial outage from 12:43 PM to 2:33 PM

Updates
  • Resolved
    Resolved

    The AMC channels have been restored. Thank you for your patience during this issue!

  • Update
    Update

    Our signal provider has confirmed they are actively engaged with AMC to fix the issue. No ETAs on a fix have been provided as of yet.

  • Identified
    Identified

    There is an active issue upstream of Philo with all channels coming from AMC Networks, and as a result they are currently down on Philo. Our signal acquisition provider is actively working on the issue. The list of impacted channels is as follows:

    • AMC

    • BBC America

    • IFC

    • Sundance TV

    • We TV

    We apologize for the inconvenience, and will update this post once we have been notified that signal is restored.