Degraded performance on Discovery channels

Resolved
Degraded performance
Started 9 months ago Lasted 7 days

Affected

Video
Updates
  • Resolved
    Resolved

    This incident has been resolved, thank you for your patience!

  • Monitoring
    Monitoring

    All outstanding alerts have been cleared and we are currently monitoring the channel feeds.

  • Identified
    Update

    Discovery has confirmed that the issue is related to the recent changes they made with video compression. They are still actively working on a solution and as of right now have not provided an ETA on when this will be fixed.

    We will continue to share updates here as soon as they become available!

  • Identified
    Identified

    We are currently experiencing issues with multiple Discovery-owned channels. The problem is at the video source, and Discovery is actively working on fixing this. Some viewers may notice frozen frames and video distortion (glitches). These issues would also be present in DVR recordings. Heavily corrupted recordings are removed automatically, so some viewers might notice that they are missing recordings of recent broadcasts.

    Affected channels

    • TLC
    • Investigation Discovery
    • Science Channel
    • Discovery Life
    • Discovery Family
    • OWN
    • Motortrend

    We will post updates as they become available.