Resolved
Support - Phone and chat system down

Started
January 10, 2024 at 11:11 PM
Status
Resolved after about 3 hours

Impact

Major outage
Affected
help.philo.com
  • Resolved
    Resolved

    This incident has been resolved. Our Support team is now able to receive calls and chats. Thank you for your patience as we worked to resolve this issue.

  • Identified
    Update

    Our team is still working with our service partner and actively monitoring while they work on a fix. We apologize for this inconvenience and hope to be online soon.

  • Identified
    Identified

    Our service provider is experiencing issues which is preventing us from answering phones and chats to our Support team. We are in contact with them and will provide updates as quickly as possible.