App Issue - Trying to play content from deep link on Android and Fire TV devices causes crash

Resolved
Degraded performance
Started 21 days ago Lasted 2 days

Affected

Apps
Updates
  • Resolved
    Resolved

    This incident has been resolved! Please make sure to update to the latest app version (7.2.15-283857)

  • Identified
    Identified

    Affected App: Amazon-v7.3.9 & Android-v7.3.9

    Identified an issue specifically on Android and Fire TV devices where trying to deep link (opening from Amazon's guide) is causing player problems such as: Black screen or Spinner (loading) screen for several minutes.

    We are continuing to work on a fix for this incident!