Philo - Support - Phone and Chat systems – Incident details

Support - Phone and Chat systems

Resolved
Operational
Started 2 months agoLasted 26 minutes

Affected

help.philo.com

Operational from 5:38 PM to 6:04 PM

Updates
  • Resolved
    Resolved

    Great news! Our phone and chat systems are back online and the issue has been resolved. We apologize for the inconvenience.

  • Investigating
    Investigating

    Our service provider is experiencing issues which is preventing us from answering phones and chats to our Support team. We are in contact with them and will provide updates as quickly as possible.