Philo - Support - Phone and Chats System – Incident details

Support - Phone and Chats System

Resolved
Degraded performance
Started about 2 months agoLasted about 1 hour

Affected

help.philo.com

Under maintenance from 11:34 AM to 12:32 PM

Updates
  • Resolved
    Resolved

    We've completed our updates! Thanks for hanging in there with us.

  • Monitoring
    Monitoring

    We’re taking a brief time out to conduct planned maintenance which may temporarily affect your ability to reach our customer support team. We apologize for any inconvenience and will do our best to be back up shortly, ready to help you out!