Philo - Video Playback Issues Under Investigation – Incident details

Video Playback Issues Under Investigation

Resolved
Operational
Started 13 days agoLasted less than a minute

Affected

Video

Operational from 9:41 PM to 9:41 PM

Sign Up

Operational from 9:41 PM to 9:41 PM

Sign In

Operational from 9:41 PM to 9:41 PM

Apps

Operational from 9:41 PM to 9:41 PM

help.philo.com

Operational from 9:41 PM to 9:41 PM

Support (chat and phone)

Operational from 9:41 PM to 9:41 PM

Updates
  • Update
    Update
    This incident has been resolved.
  • Resolved
    Resolved

    Our engineers are investigating an issue causing problems for some customers with the video player.