Philo - Issues with Amazon billed accounts getting deactivated – Incident details

Apps experiencing degraded performance

Issues with Amazon billed accounts getting deactivated

Identified
Major outage
Started about 13 hours ago

Affected

Apps

Major outage from 2:42 AM to 7:42 AM, Under maintenance from 7:42 AM to 3:00 PM, Degraded performance from 3:00 PM to 12:00 AM

Updates
  • Update
    Update

    We are aware that there are some Amazon billed customers that are still affected by the Amazon Outage. Our engineers our continuing to work on restoring access to customers who were impacted.

  • Identified
    Identified

    Amazon confirmed they identified the issue and are working on a fix. Our engineers are also working on restoring access for impacted customers.

  • Investigating
    Investigating
    We are currently investigating this incident.