Resolved
System issues across the board

Started
November 14, 2022 at 1:58 AM
Status
Resolved after 16 minutes

Impact

Operational
Affected
Apps
Sign In
Sign Up
Video
  • Resolved
    November 14, 2022 at 2:14 AM

    Good news, everyone! We resolved the issue and all systems are operational. Our team will continue to monitor.

  • Identified
    November 14, 2022 at 1:58 AM

    We are aware of a multitude of issues users are experiencing with the system right now. Our best and brightest engineers are on the case and we are working to get this fixed as quickly as possible!

    Please note: Season 5 episode 1 of Yellowstone is scheduled to re-air immediately after the premiere.