Customer Support

Resolved
Operational
Started about 1 year ago Lasted about 1 hour

Affected

help.philo.com
Updates
  • Resolved
    Resolved

    We are happy to share that our customer support team is back online!

  • Investigating
    Investigating

    We are aware of an issue where customers are unable to contact our support team. We are currently working with one of our partners who have identified an issue on their end. We will post updates as we get them and appreciate you hanging in there with us.