Show current status

[Resolved] Problems with billing system

Started on April 18, 2021 at 2:25 AM. Resolved after 40 minutes

Affected

Sign Up
  • Identified
    April 18, 2021 at 2:25 AM  –  

    We are seeing an elevated error rate with our billing system provider and are actively investigating with them.

  • Resolved
    April 18, 2021 at 3:04 AM  –  

    The issue is now resolved.