[Resolved] Philo not loading

Started on June 23, 2021 at 11:24 PM. Resolved after 30 minutes

Affected

Video
  • Investigating
    June 23, 2021 at 11:24 PM

    We are seeing issues with customers loading Philo, often times with an error mentioning DRM. Our engineers are on the case and working to repair things. We will post updates as things progress.

  • Monitoring
    June 23, 2021 at 11:43 PM

    We believe we have fixed the problem and are monitoring things to make sure this is truly resolved.

  • Resolved
    June 23, 2021 at 11:55 PM

    Good news, everyone! Engineering has officially sounded the all-clear and the issue is now fully resolved.