[Resolved] Some users unable to sign up.

Started on December 15, 2021 at 7:45 PM. Resolved after about 1 hour

Affected

Sign Up
  • Identified
    December 15, 2021 at 7:45 PM

    Some customers are reporting an issue during sign-up or when making changes to their account. This is also impacting our support team's ability to access accounts. We've identified the issue and are actively working to resolve this.

  • Resolved
    December 15, 2021 at 8:52 PM

    We just resolved the issue!