[Resolved] Some users unable to sign up.

Started on December 22, 2021 at 1:23 PM. Resolved after about 1 hour

Affected

Sign Up
  • Investigating
    December 22, 2021 at 1:23 PM

    Some customers are reporting an issue during sign-up or when making changes to their account. This is also impacting our support team's ability to access accounts. We've identified the issue and are actively working to resolve this.

  • Identified
    December 22, 2021 at 1:53 PM

    It's looking like these issues are related to the AWS outage that is currently being resolved: https://status.aws.amazon.com/

  • Resolved
    December 22, 2021 at 2:24 PM

    Looks like things are getting back to normal!