Philo - Email sign-up and sign-in codes are not being delivered – Incident details

Email sign-up and sign-in codes are not being delivered

Resolved
Major outage
Started 6 days agoLasted about 4 hours

Affected

Sign Up

Major outage from 9:51 PM to 10:14 PM, Degraded performance from 10:14 PM to 1:47 AM

Sign In

Partial outage from 9:51 PM to 10:14 PM, Degraded performance from 10:14 PM to 1:47 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    Our email delivery service looks to be improving and getting sign-up and sign-in issues resolved! There may be some codes that are have timed out, so signing back in to get a new code might be required.

    We'll continue to monitor the status until we have confirmed the issue to be fully resolved.

  • Identified
    Identified

    An external service used to deliver email codes for our sign-up and sign-in flows are currently impacted. This service is actively investigating the issue.

    Temporary workaround for existing customers is to use an already linked mobile number to your account as your sign-in method.